All about Router

IOS Commands Part A

Home | Explaination | Cisco Router Hardware | Router Configuration | Router Working | IOS - A | IOS-B | IOS-C | STP | VLAN | Layer 2 Switching | Last Minute Revision - CCNA IOS | ISDN | IPX | IP Addressing | FREQUENT | Subnet | Router Configuration | LMR-CCNA | Cisco Secret | Cisco IOS Basic Commands | Glossary | Working | Switch Working | OSI | VPN | Firewalls | NAT

ROUTER COMMANDS

TERMINAL CONTROLS:
  • Config# terminal editing - allows for enhanced editing commands
  • Config# terminal monitor - shows output on telnet session
  • Config# terminal ip netmask-format hexadecimal|bit-count|decimal - changes the format of subnet masks

    HOST NAME:
  • Config# hostname ROUTER_NAME

    BANNER:
  • Config# banner motd # TYPE MESSAGE HERE # - # can be substituted for any character, must start and finish the message

    DESCRIPTIONS:
  • Config# description THIS IS THE SOUTH ROUTER - can be entered at the Config-if level

    CLOCK:
  • Config# clock timezone Central -6
    # clock set hh:mm:ss dd month yyyy
    - Example: clock set 14:35:00 25 August 2003

    CHANGING THE REGISTER:
  • Config# config-register 0x2100 - ROM Monitor Mode
  • Config# config-register 0x2101 - ROM boot
  • Config# config-register 0x2102 - Boot from NVRAM

    BOOT SYSTEM:
  • Config# boot system tftp FILENAME SERVER_IP - Example: boot system tftp 2600_ios.bin 192.168.14.2
  • Config# boot system ROM
  • Config# boot system flash - Then - Config# reload

    CDP:
  • Config# cdp run - Turns CDP on
  • Config# cdp holdtime 180 - Sets the time that a device remains. Default is 180
  • Config# cdp timer 30 - Sets the update timer.The default is 60
  • Config# int Ethernet 0
  • Config-if# cdp enable - Enables cdp on the interface
  • Config-if# no cdp enable - Disables CDP on the interface
  • Config# no cdp run - Turns CDP off

    HOST TABLE:
  • Config# ip host ROUTER_NAME INT_Address - Example: ip host lab-a 192.168.5.1
    -or-
  • Config# ip host RTR_NAME INT_ADD1 INT_ADD2 INT_ADD3 - Example: ip host lab-a 192.168.5.1 205.23.4.2 199.2.3.2 - (for e0, s0, s1)

    DOMAIN NAME SERVICES:
  • Config# ip domain-lookup - Tell router to lookup domain names
  • Config# ip name-server 122.22.2.2 - Location of DNS server
  • Config# ip domain-name cisco.com - Domain to append to end of names

    CLEARING COUNTERS:
  • # clear interface Ethernet 0 - Clears counters on the specified interface
  • # clear counters - Clears all interface counters
  • # clear cdp counters - Clears CDP counters

    STATIC ROUTES:
  • Config# ip route Net_Add SN_Mask Next_Hop_Add - Example: ip route 192.168.15.0 255.255.255.0 205.5.5.2
  • Config# ip route 0.0.0.0 0.0.0.0 Next_Hop_Add - Default route
    -or-
  • Config# ip default-network Net_Add - Gateway LAN network

    IP ROUTING:
  • Config# ip routing - Enabled by default
  • Config# router rip
    -or-
  • Config# router igrp 100
  • Config# interface Ethernet 0
  • Config-if# ip address 122.2.3.2 255.255.255.0
  • Config-if# no shutdown

    IPX ROUTING:
  • Config# ipx routing
  • Config# interface Ethernet 0
  • Config# ipx maximum-paths 2 - Maximum equal metric paths used
  • Config-if# ipx network 222 encapsulation sap - Also Novell-Ether, SNAP, ARPA on Ethernet. Encapsulation HDLC on serial
  • Config-if# no shutdown

    ACCESS LISTS:
  • IP Standard 1-99
    IP Extended 100-199
    IPX Standard 800-899
    IPX Extended 900-999
    IPX SAP Filters 1000-1099

    IP STANDARD:

  • Config# access-list 10 permit 133.2.2.0 0.0.0.255 - allow all src ip’s on network 133.2.2.0
    -or-
  • Config# access-list 10 permit host 133.2.2.2 - specifies a specific host
    -or-
  • Config# access-list 10 permit any - allows any address

  • Config# int Ethernet 0
  • Config-if# ip access-group 10 in - also available: out

    IP EXTENDED:
  • Config# access-list 101 permit tcp 133.12.0.0 0.0.255.255 122.3.2.0 0.0.0.255 eq telnet
        -protocols: tcp, udp, icmp, ip (no sockets then), among others
        -source then destination address
        -eq, gt, lt for comparison
        -sockets can be numeric or name (23 or telnet, 21 or ftp, etc)
    -or-
  • Config# access-list 101 deny tcp any host 133.2.23.3 eq www
    -or-
  • Config# access-list 101 permit ip any any

  • Config# interface Ethernet 0
  • Config-if# ip access-group 101 out

    IPX STANDARD:
  • Config# access-list 801 permit 233 AA3 - source network/host then destination network/host
    -or-
  • Config# access-list 801 permit -1 -1 - “-1” is the same as “any” with network/host addresses

  • Config# interface Ethernet 0
  • Config-if# ipx access-group 801 out

    IPX EXTENDED:
  • Config# access-list 901 permit sap 4AA all 4BB all
        - Permit protocol src_add socket dest_add socket
        -“all” includes all sockets, or can use socket numbers
    -or-
  • Config# access-list 901 permit any any all any all
        -Permits any protocol with any address on any socket to go anywhere

  • Config# interface Ethernet 0
  • Config-if# ipx access-group 901 in

    IPX SAP FILTER:
  • Config# access-list 1000 permit 4aa 3 - “3” is the service type
    -or-
  • Config# access-list 1000 permit 4aa 0 - service type of “0” matches all services

  • Config# interface Ethernet 0
  • Config-if# ipx input-sap-filter 1000 - filter applied to incoming packets
    -or-
  • Config-if# ipx output-sap-filter 1000 - filter applied to outgoing packets

    NAMED ACCESS LISTS:
  • Config# ip access-list standard LISTNAME
        -can be ip or ipx, standard or extended
        -followed by the permit or deny list
  • Config# permit any

  • Config-if# ip access-group LISTNAME in
        -use the list name instead of a list number
        -allows for a larger amount of access-lists

    PPP SETUP:
  • Config-if# encapsulation ppp
  • Config-if# ppp authentication chap pap
        -order in which they will be used
        -only attempted with the authentification listed
        -if one fails, then connection is terminated
  • Config-if# exit
  • Config# username Lab-b password 123456
        -username is the router that will be connecting to this one
        -only specified routers can connect
    -or-
  • Config-if# ppp chap hostname ROUTER
  • Config-if# ppp chap password 123456
        -if this is set on all routers, then any of them can connect to any other
        -set same on all for easy configuration

    ISDN SETUP:
  • Config# isdn switch-type basic-5ess - determined by telecom
  • Config# interface serial 0
  • Config-if# isdn spid1 2705554564 - isdn “phonenumber” of line 1
  • Config-if# isdn spid2 2705554565 - isdn “phonenumber” of line 2
  • Config-if# encapsulation PPP - or HDLC, LAPD

    DDR - 4 Steps to setting up ISDN with DDR
    1. Configure switch type
      Config# isdn switch-type basic-5ess - can be done at interface config

    2. Configure static routes
      Config# ip route 123.4.35.0 255.255.255.0 192.3.5.5 - sends traffic destined for 123.4.35.0 to 192.3.5.5
      Config# ip route 192.3.5.5 255.255.255.255 bri0 - specifies how to get to network 192.3.5.5 (through bri0)

    3. Configure Interface
      Config-if# ip address 192.3.5.5 255.255.255.0
      Config-if# no shutdown
      Config-if# encapsulation ppp
      Config-if# dialer-group 1 - applies dialer-list to this interface
      Config-if# dialer map ip 192.3.5.6 name Lab-b 5551212
          connect to lab-b at 5551212 with ip 192.3.5.6 if there is interesting traffic
          can also use “dialer string 5551212” instead if there is only one router to connect to

    4. Specify interesting traffic
      Config# dialer-list 1 ip permit any
      -or-
      Config# dialer-list 1 ip list 101 - use the access-list 101 as the dialer list

    5. Other Options
      Config-if# hold-queue 75 - queue 75 packets before dialing
      Config-if# dialer load-threshold 125 either
          -load needed before second line is brought up
          -“125” is any number 1-255, where % load is x/255 (ie 125/255 is about 50%)
          -can check by in, out, or either
      Config-if# dialer idle-timeout 180
          -determines how long to stay idle before terminating the session
          -default is 120
    FRAME RELAY SETUP:
  • Config# interface serial 0
  • Config-if# encapsulation frame-relay - cisco by default, can change to ietf
  • Config-if# frame-relay lmi-type cisco - cisco by default, also ansi, q933a
  • Config-if# bandwidth 56

  • Config-if# interface serial 0.100 point-to-point - subinterface
  • Config-if# ip address 122.1.1.1 255.255.255.0
  • Config-if# frame-relay interface-dlci 100
        -maps the dlci to the interface
        -can add BROADCAST and/or IETF at the end

  • Config-if# interface serial 1.100 multipoint
  • Config-if# no inverse-arp - turns IARP off; good to do
  • Config-if# frame-relay map ip 122.1.1.2 48 ietf broadcast
        -maps an IP to a dlci (48 in this case)
        -required if IARP is turned off
        -ietf and broadcast are optional
  • Config-if# frame-relay map ip 122.1.1.3 54 broadcast

    SHOW COMMANDS

  • Show access-lists - all access lists on the router
  • Show cdp - cdp timer and holdtime frequency
  • Show cdp entry * - same as next
  • Show cdp neighbors detail - details of neighbor with ip add and ios version
  • Show cdp neighbors - id, local interface, holdtime, capability, platform portid
  • Show cdp interface - int’s running cdp and their encapsulation
  • Show cdp traffic - cdp packets sent and received
  • Show controllers serial 0 - DTE or DCE status
  • Show dialer - number of times dialer string has been reached, other stats
  • Show flash - files in flash
  • Show frame-relay lmi - lmi stats
  • Show frame-relay map - static and dynamic maps for PVC’s
  • Show frame-relay pvc - pvc’s and dlci’s
  • Show history - commands entered
  • Show hosts - contents of host table
  • Show int f0/26 - stats of f0/26
  • Show interface Ethernet 0 - show stats of Ethernet 0
  • Show ip - ip config of switch
  • Show ip access-lists - ip access-lists on switch
  • Show ip interface - ip config of interface
  • Show ip protocols - routing protocols and timers
  • Show ip route - Displays IP routing table
  • Show ipx access-lists - same, only ipx
  • Show ipx interfaces - RIP and SAP info being sent and received, IPX addresses
  • Show ipx route - ipx routes in the table
  • Show ipx servers - SAP table
  • Show ipx traffic - RIP and SAP info
  • Show isdn active - number with active status
  • Show isdn status - shows if SPIDs are valid, if connected
  • Show mac-address-table - contents of the dynamic table
  • Show protocols - routed protocols and net_addresses of interfaces
  • Show running-config - dram config file
  • Show sessions - connections via telnet to remote device
  • Show startup-config - nvram config file
  • Show terminal - shows history size
  • Show trunk a/b - trunk stat of port 26/27
  • Show version - ios info, uptime, address of switch
  • Show vlan - all configured vlan’s
  • Show vlan-membership - vlan assignments
  • Show vtp - vtp configs

    CATALYST COMMANDS
    For Native IOS - Not CatOS

    SWITCH ADDRESS:
  • Config# ip address 192.168.10.2 255.255.255.0
  • Config# ip default-gateway 192.168.10.1

    DUPLEX MODE:
  • Config# interface Ethernet 0/5 - “fastethernet” for 100 Mbps ports
  • Config-if# duplex full - also, half | auto | full-flow-control

    SWITCHING MODE:
  • Config# switching-mode store-and-forward - also, fragment-free

    MAC ADDRESS CONFIGS:
  • Config# mac-address-table permanent aaab.000f.ffef e0/2 - only this mac will work on this port
  • Config# mac-address-table restricted static aaab.000f.ffef e0/2 e0/3
        -port 3 can only send data out port 2 with that mac
        -very restrictive security

  • Config-if# port secure max-mac-count 5 - allows only 5 mac addresses mapped to this port

    VLANS:
  • Config# vlan 10 name FINANCE
  • Config# interface Ethernet 0/3
  • Config-if# vlan-membership static 10

    TRUNK LINKS:
  • Config-if# trunk on - also, off | auto | desirable | nonegotiate
  • Config-if# no trunk-vlan 2
        -removes vlan 2 from the trunk port
        -by default, all vlans are set on a trunk port

    CONFIGURING VTP:
  • Config# delete vtp - should be done prior to adding to a network
  • Config# vtp server - the default is server, also client and transparent
  • Config# vtp domain Camp - name doesn’t matter, just so all switches use the same
  • Config# vtp password 1234 - limited security
  • Config# vtp pruning enable - limits vtp broadcasts to only switches affected
  • Config# vtp pruning disable

    FLASH UPGRADE:
  • Config# copy tftp://192.5.5.5/configname.ios opcode - “opcode” for ios upgrade, “nvram” for startup config

    DELETE STARTUP CONFIG:
  • Config# delete nvram
  • Router commands

    Usermode Commands

    Sl. No.

    Command

    Comments, if any.

    1

    disconnect

     Terminates the suspended telnet session and then logout it.

    2

    enable

     

    3

    ping <host-name>

     Used to tests the connectivity.It uses ICMP to initiate the connection.

    4

    ping <ip-address>

     

    5

    traceroute <hostname>

     Lists all routers along path to destination and finds the routing problems if any.

    6

    traceroute <ip-address>

     

     

    Privilegemode Commands

    Sl. No.

    Command

    Comments, if any.

    1

    clear arp-cache

     

    2

    configure terminal

     Allows to execute commands that change the router's configuration.

    3

    copy running-config startup-config

     It saves the active configuration of the router.

    4

    copy startup-config running-config

     

    5

    debug ip packet 

     

    6

    disable 

     Returns to the UserEXEC mode from Privilege mode.

    7

    disconnect <TELNET_ID>

     

    8

    erase startup-config

     Deletes all the configuration files present on a router.

    9

    logout 

     It exits router from the user or privilege mode.

    10

    ping <host-name>

     Used to tests the connectivity.It uses ICMP to initiate the connection.

    11

    ping <ip-address>

     

    12

    reload

     

    13

    resume <TELNET_ID>

     

    14

    show access-list 

     Displays all accesslists from all protocols present in a specified router.

    15

    show banner 

     

    16

    show cdp  

     Shows the status of CDP such as holdtime value,no.of packets for every 60sec.

    17

    show cdp interface  

     It tells the CDP configuration on an interface-by-interface basis.

    18

    show cdp neighbor 

     

    19

    show cdp traffic 

     

    20

    show clock 

     

    21

    show flash 

     Used to view all IOS images and file stored in flash(Default location of IOS images is in flash).

    22

    show frame-relay lmi 

     Shows the detailed statistics regarding LMI.

    23

    show frame-relay map 

     

    24

    show frame-relay pvc <dlci_num> 

     Shows all the frame relay PVC's terminated and their statistics at a specified router.

    25

    show history

     Shows the previously executed commands.IOS device stores the last ten commands that are executed.

    26

    show hosts

     

    27

    show interfaces

     To view interfaces,status,and statistics for an interface.If u don't lists a specific interface,all of the interfaces on the router are listed.

    28

    show interfaces ethernet 0

     

    29

    show interfaces loopback 0

     

    30

    show interfaces serial 0

     displays the lmi type that is being used and also sme LMI statisstics.

    31

    show ip arp

     

    32

    show ip eigrp neighbors

     Shows the list of eigrp neighbors that a specified router has.

    33

    show ip eigrp neighbors detail

     

    34

    show ip eigrp topology

     Displays the list of successor and feasible successors,as well as other types of routes.

    35

    show ip eigrp traffic

     It shows the information about trafiic statistics for eigrp

    36

    show ip interface

     

    37

    show ip interface brief

     Verifies the IP configuration.

    38

    show ip ospf database

     

    39

    show ip ospf interface

     

    40

    show ip ospf neighbor detail 

     

    41

    show ip route

     Verifies the configurationof static and default routes on a router.

    42

    show protocols

     Displays the routing protocols that have been configured and running on a specified router.

    43

    show running-config

     

    44

    show sessions

     shows the telnet sessions that are currently suspended.

    45

    show startup-config 

     

    46

    show version 

     Display version information for the hardware and firmware.

    47

    telnet <host-name>

     

    48

    telnet <IP-address>

     

    49

    traceroute <hostname>

     

    50

    traceroute <ip-address>

     Lists all routers along path to destination and finds the routing problems if any.

    51

    vlan database

     Used to access all VLAN and VTP configuration.

    52

    write erase

     

    53

    write memory

     

    54

    write terminal

     

     

    Global configuration mode Commands

    Sl. No.

    Command

    Comments, if any.

    1

    access-list <list-num> {permit | deny} <source-ip-address> 

    Only standard access list of the format given is supported.

    2

    access-list <list-num> {permit | deny} <any>

     

    3

    access-list <list-num> {permit | deny} <ip-address> <ip-address>

     

    4

    access-list <list-num> {permit | deny} <host-name> <ip-address>

     

    5

    banner motd <banner>

     It creates the login banner on a specified router.

    6

    cdp advertise-v2

     

    7

    cdp holdtime <seconds>

     

    8

    cdp run

     

    9

    cdp timer <seconds>

     

    10

    config-register <value>

    Hexadecimal or decimal value that represents the 16-bit configuration register value. It is used at the router start-up. The value range is from 0x0 to 0xFFFF (0 to 65535 in decimal). Normally, the default value is 0x2102

    11

    dialer-list<list-num>protocol ip permit

     

    12

    enable password <password>

     Sets the paasword.The level number is either 1 or 15.

    13

    enable secret <password>

     Encrypts the password when it is saved.

    14

    end 

     

    15

    hostname <host-name>

     

    16

    interface ethernet 0

     Used to access ethernet interface and enter Interface subconfiguration mode.

    17

    interface fastethernet <pnum>

     

    18

    interface loopback 0

     Used to create loopback interface.Port numbers can specify between 0 to 2147483647.

    19

    interface serial 0 

     

    20

    interface vlan <vlan_num>

     

    21

    ip default-gateway <ip-address>

     Tells the router which router to use when the router needs to reach the destination thats not in its configured subnet.

    22

    ip default-network <ip-address>

     

    23

    ip domain-lookup 

     

    24

    ip host <name> <ip-address>

    Complete syntax for this command: ip host name [tcp-port-number] address1 [address2...address8]

    25

    ip name-server<ip-address>

     By using this Router access the DNS server to resolve the names to ip addresses.

    26

    ip route <prefix> <mask> {next-hop-ip-addr | interface-type}

    The command supported by the simulator are:
    ip route <prefix> <mask> <next-hop-ip> and
    ip route <prefix> <mask> serial 

    27

    ip route 0.0.0.0 0.0.0.0 <ip-address>

     

    28

    ip route<ip-address> <ip-address> <ip-address>

     

    29

    ip route <ip-address> <ip-address> serial 0

    Not supported at this time

    30

    ip routing

     

    31

    ipx routing

     

    32

    isdn switch-type <switch_type>

     

    33

    line aux

     

    34

    line console 0 

     To enter into console interface.Here 0 specifies the console part.

    35

    line vty

     It supports 16 simultaneous telnet connections and each connection is internally tracked by a number:0-15.

    36

    no banner motd

     

    37

    no cdp run

     It can globally enable or disable the cdp on a router.

    38

    no ip domain-lookup

     It disables all the DNS lookups on the router.

    39

    no ip routing

     

    40

    no router eigrp

     

    41

    no router ospf

     

    42

    no router rip

     

    43

    no vlan <vlan_num>

     

    44

    router eigrp <aut_sys>

     

    45

    router ospf <proc_id>

     Process_id is locally significant and is used to differentiate different ospf processes running on a router.

    46

    router rip

     Enters into the RIP routing protocol configuration mode.

    47

    snmp-server enable traps vtp

     

    48

    username <name> password <password>

     

     

    Interface subconfiguration mode Commands

    Sl. No.

    Command

    Comments, if any.

    1

    bandwidth <kilobits>

    Required bandwidth, in kilobits per second.

    2

    cdp enable 

     

    3

    clock rate <bps>

    Desired clock rate in bits per second: 1200, 2400, 4800, 9600, 19200, 38400, 56000, 64000 etc.

    4

    compress stac <num> in

     

    5

    description <string>

    Character string from 1 to 80 characters.

    6

    dialer-group<dialer_list_#>

     

    7

    dialer map ip <ip-address> <des-phone>

     

    8

    dialer map ip <ip-address> name <hostname> <des-phone>

     

    9

    dialer string< phone_#> <class map_name>

     

    10

    encapsulation  <encapsulation-type>

    Only PPP/HDLC are supported at this time by the simulator.
    ex: encapsulation hdlc

    11

    encapsulation framerelay<num> in

     

    12

    frame-relay lmi-type <lmi_type>

     Specifies the LMI type that is used to communicate between a router and carrier's switch.LMI type is specific to the entire interface,not to a VC.

    13

    frame-relay map<protocol-name> <ip-address> <dlci_num>

     It configures the manual resolution of PVC's.

    14

    frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast

     

    15

    frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast cisco

     

    16

    frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast ietf

     

    17

    frame-relay map<protocol-name> <ip-address> <dlci_num> cisco

     

    18

    frame-relay map<protocol-name> <ip-address> <dlci_num> ietf

     

    19

    ip access-group <num> in

     

    20

    ip access-group <num> out 

     

    21

    ip address <ip-address> <sub-net mask> 

     

    22

    isdn spid1<spid_num>

     Defines the spid's that are used to authenticate call requests.Used only on local connection between router and isdn switch.

    23

    isdn spid2<spid_num>

     

    24

    keepalive <seconds>

     

    25

    login

     

    26

    no bandwidth

     

    27

    no cdp enable

     

    28

    no clock rate

     

    29

    no frame map <protocol name> <ip-address> <dlci_num>

     

    30

    no frame map<protocol-name> <ip-address> <dlci_num> broadcast

     

    31

    no frame map<protocol-name> <ip-address> <dlci_num> cisco

     

    32

    no frame map<protocol-name> <ip-address> <dlci_num> ietf

     

    33

    no ip address

     

    34

    no shutdown

     

    35

    shutdown

     It disable the interfaces.Interfaces are enabled by default.

    36

    shutdown switchport

     

    37

    speed

     

    38

    switchport access vlan <vlan_num>

     

    39

    switchport port-security mac-address sticky<mac_addr>

     

    40

    switchport port-security maximum <max_macadd>

     

    41

    switchport port-security violation <violat_mode>

     

     

    Line subconfiguration mode Commands

    Sl. No.

    Command

    Comments, if any.

    1

    exec-timeout <minutes> [seconds] 

    seconds is optional. 

    2

    logging synchronous

     

    3

    password <password> 

     

     

    Subinterface Subconfiguration mode Commands

    Sl. No.

    Command

    Comments, if any.

    1

    discription<string>

     It specifies the DLCI number.Uses a dynamic resolution with inverse ARP.

    2

    frame-relay interface-dlci<dlci_num>

     It specifies the DLCI number.Uses a dynamic resolution with inverse ARP.

    3

    frame-relay map<protocol-name> <ip-address> <dlci_num>

     

    4

    frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast

     

    5

    frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast cisco

     

    6

    frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast ietf

     

    7

    frame-relay map<protocol-name> <ip-address> <dlci_num> cisco

     

    8

    frame-relay map<protocol-name> <ip-address> <dlci_num> ietf

     

    9

    ip address<ip-address> <subnet-mask>

     

    10

    no ip address

     

    11

    no shutdown

     It specifies the DLCI number.Uses a dynamic resolution with inverse ARP.

    12

    shutdown

     It specifies the DLCI number.Uses a dynamic resolution with inverse ARP.

     

    IP Routing Protocol Subconfiguration mode Commands

    Sl. No.

    Command

    Comments, if any.

    1

    network <ip-address>

     Used with routing rip, igrp etc.

     

    Supported Switch Commands

    User mode Commands 
    Sl.No. commands Comments, if any.
    1 enable  

     

    Privilegemode Commands 

    Sl.No. commands Comments, if any.
    1 clock set hh:mm:ss <1-31> Month <2004-2035>  
    2 configure terminal  Allows to execute commands that change the switch's configuration.
    3 copy running-config startup-config  It saves the active configuration of the switch.

    4 copy startup-config running-config  
    5 disable  Returns to the UserEXEC mode from Privilege mode.
    6 erase startup-config  
    7 logout  It exits switch from the user or privilege mode.
    8 reload  
    9 show banner  
    10 show flash  Used to view all IOS images and file stored in flash(Default location of IOS images is in flash).
    11 show history  
    12 show interfaces  To view interfaces,status,and statistics for an interface.If u don't lists a specific interface,all of the interfaces on the switch are listed.
    13 show ip interface brief  Verifies the IP configuration.
    14 show running-config  It examine the active configuration on a switch.
    15 show startup-config  
    16 show version Display version information for the hardware  and firmware
    Global Configuration mode Commands 
    Sl.No. commands Comments, if any.
    1 banner motd <phrase>  It creates the login banner on a specified router.
    2 cdp advertise-v2  
    3 cdp holdtime <seconds>  
    4 cdp run  
    5 cdp timer <seconds>  
    6 enable password <password>  It sets the paasword.The level number is either 1 or 15.
    7 enable secret <secret>  Encrypts the password when it is saved.
    8 end  
    9 hostname <name>  
    10 ip default-gateway <ip-address>  Tells the switch which router or switch have to use when the switch needs to reach the destination thats not in its configured subnet.
    11 ip host<hostname> <ip-address>  
    12 interface fastethernet <0-0>/<0-24> Depends on the switch type. For module 0, port 1 the command is interface fastethernet 0/1
    13 interface vlan <vlan #> You can enter interface config mode.
    example: interface vlan 1
    (config-if)#ip address 192.168.10.1 255.255.255.0
    14 line console 0  
    15 line vty 0 15  
    16 mac-address-table static <mac-address> vlan <valn_num> interface fastethernet <pnum>  
    17 snmp-server enable traps vtp  
    18 speed <speed> Enter switch port speed 10,100, auto. 

     

    Interface Subconfiguration mode Commands 

    Sl.No. commands Comments, if any.
    1 description <phrase>  
    2 duplex <duplex-type>  
    3 ip address <ip-address> <subnet mask> A switch can have one IP address. The IP address of the switch can be accessed only through ports that belong to the management VLAN. 
    4 ip name-server <ip-address>  
    5 login  
    6 no ip address  
    7 no shutdown  It reenables the interface when the interface is disabled.By default interfaces are enabled.
    8 no switchport <port_security>  
    9 shutdown Disables a port and shuts-down management vlan. no shutdown command enables a port.

     

    Line Subconfiguration mode Commands 

    Sl.No. commands Comments, if any.
    1 password <password>  

     

    Vlan mode Commands 

    Sl.No. commands Comments, if any.

    1

    vlan<vlan_num>

     VLAN numbers can range 1-1000,However only 64VLANs can be active ata time.

    2

    vtp client

     Specifies the VTP mode of the switch.

    3

    vtp domain

     Defines the domain name for a specified switch.For switches to share VTP informtion they must be in the same domain.

    4

    vtp password

     

    5

    vtp pruning

     

    6

    vtp server

     

    7

    vtp transparent

     

    Workstation Commands

    Sl. No.

    Command

    Comments, if any.

    1

    ip address <ip-address> <subnet-mask>

     

    2

    ping <ip-address>

     

    3

    ping <hostname>

     

    4

    telnet <host-name>

     

    5

    telnet <ip-address>

     

    6

    traceroute <hostname>

     

    7

    traceroute <ip-address>

     

    -------Jagdeep Yadav